ImportError: Importing the multiarray numpy extension module failed

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

ImportError: Importing the multiarray numpy extension module failed

Amit Bhosle
Hi,

I'm struggling with a numpy issue and web search hasn't helped. I'm on windows 10, and using Python27.

I've tried reinstalling numpy, and also a few different versions, but without any luck.

numpy was pulled in as dependency of timezonefinder==1.5.7 that i need, and the numpy-1.12.0.dist-info distribution was installed..

The error on my google-app-engine server's console is as below..
Can someone pls help?

thanks a bunch in advance.. 
AB


  File "timezonefinder\timezonefinder.py", line 8, in <module>
    from numpy import array, empty, fromfile
  File "numpy\__init__.py", lin                                                       e 142, in <module>
    from . import add_newdocs
  File "numpy\add_newdocs.py",                                                        line 13, in <module>
    from numpy.lib import add_newdoc
  File "numpy\lib\__init__.py",                                                        line 8, in <module>
    from .type_check import *
  File "numpy\lib\type_check.py                                                       ", line 11, in <module>
    import numpy.core.numeric as _nx
  File "numpy\core\__init__.py"                                                       , line 24, in <module>
    raise ImportError(msg)
ImportError:
Importing the multiarray numpy extension module failed.  Most
likely you are trying to import a failed build of numpy.
If you're working with a numpy git repo, try `git clean -xdf` (removes all
files not under version control).  Otherwise reinstall numpy.

_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.scipy.org/mailman/listinfo/numpy-discussion
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ImportError: Importing the multiarray numpy extension module failed

Nathaniel Smith
On Tue, Feb 14, 2017 at 8:24 PM, Amit Bhosle <[hidden email]> wrote:

> Hi,
>
> I'm struggling with a numpy issue and web search hasn't helped. I'm on
> windows 10, and using Python27.
>
> I've tried reinstalling numpy, and also a few different versions, but
> without any luck.
>
> numpy was pulled in as dependency of timezonefinder==1.5.7 that i need, and
> the numpy-1.12.0.dist-info distribution was installed..
>
> The error on my google-app-engine server's console is as below..
> Can someone pls help?

Are you using the app engine "standard environment"? That's a very
weird Python environment that forbids the installation of all packages
that contain C code. This obviously includes numpy, and would explain
your error. They do provide a pre-installed super-ancient version of
numpy with some features removed, which might work for you if you
force-uninstall numpy. Otherwise you might need to switch to the
"flexible environment".

-n

--
Nathaniel J. Smith -- https://vorpus.org
_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.scipy.org/mailman/listinfo/numpy-discussion
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ImportError: Importing the multiarray numpy extension module failed

Amit Bhosle

Hi Nathan,

Thanks for the quick response. Yeah - looks like the Google app engine supports only 1.6.1.. Reverting to that version has fixed this issue.

Thanks
AB


On Feb 14, 2017 21:01, "Nathaniel Smith" <[hidden email]> wrote:
On Tue, Feb 14, 2017 at 8:24 PM, Amit Bhosle <[hidden email]> wrote:
> Hi,
>
> I'm struggling with a numpy issue and web search hasn't helped. I'm on
> windows 10, and using Python27.
>
> I've tried reinstalling numpy, and also a few different versions, but
> without any luck.
>
> numpy was pulled in as dependency of timezonefinder==1.5.7 that i need, and
> the numpy-1.12.0.dist-info distribution was installed..
>
> The error on my google-app-engine server's console is as below..
> Can someone pls help?

Are you using the app engine "standard environment"? That's a very
weird Python environment that forbids the installation of all packages
that contain C code. This obviously includes numpy, and would explain
your error. They do provide a pre-installed super-ancient version of
numpy with some features removed, which might work for you if you
force-uninstall numpy. Otherwise you might need to switch to the
"flexible environment".

-n

--
Nathaniel J. Smith -- https://vorpus.org
_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.scipy.org/mailman/listinfo/numpy-discussion

_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.scipy.org/mailman/listinfo/numpy-discussion
Loading...