Installing numpy

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing numpy

Lianyuan Zheng
Hello,

On my linux server, I downloaded the NUMPY package from GitHub (git clone https://github.com/numpy/numpy.git) and then accessed the directory "numpy".  When I typed command "python setup.py install", it shows the following message:

  File "setup.py", line 51
    f"NumPy {VERSION} may not yet support Python "
                                                 ^
SyntaxError: invalid syntax

Obviously the installation failed.  Which python version is needed for this numpy package?  The python version installed is version 2.7.5.

Thanks,
Lianyuan




_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Installing numpy

Stanley Seibert
The development version of NumPy from Github requires Python 3.7 or later.

On Fri, Dec 11, 2020 at 1:35 PM Lianyuan Zheng <[hidden email]> wrote:
Hello,

On my linux server, I downloaded the NUMPY package from GitHub (git clone https://github.com/numpy/numpy.git) and then accessed the directory "numpy".  When I typed command "python setup.py install", it shows the following message:

  File "setup.py", line 51
    f"NumPy {VERSION} may not yet support Python "
                                                 ^
SyntaxError: invalid syntax

Obviously the installation failed.  Which python version is needed for this numpy package?  The python version installed is version 2.7.5.

Thanks,
Lianyuan



_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion

_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Installing numpy

Lianyuan Zheng
Hi Stanley,

Thank you!

Lianyuan

On Fri, Dec 11, 2020 at 2:49 PM Stanley Seibert <[hidden email]> wrote:
The development version of NumPy from Github requires Python 3.7 or later.

On Fri, Dec 11, 2020 at 1:35 PM Lianyuan Zheng <[hidden email]> wrote:
Hello,

On my linux server, I downloaded the NUMPY package from GitHub (git clone https://github.com/numpy/numpy.git) and then accessed the directory "numpy".  When I typed command "python setup.py install", it shows the following message:

  File "setup.py", line 51
    f"NumPy {VERSION} may not yet support Python "
                                                 ^
SyntaxError: invalid syntax

Obviously the installation failed.  Which python version is needed for this numpy package?  The python version installed is version 2.7.5.

Thanks,
Lianyuan



_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion
_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion

_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Installing numpy

Lianyuan Zheng
In reply to this post by Stanley Seibert
Hello,

When I run the command "python numpy install", it shows the following error:

Traceback (most recent call last):
  File "setup.py", line 27, in <module>
    import versioneer
  File "./numpy/versioneer.py", line 1739
    file=sys.stderr)
        ^
SyntaxError: invalid syntax

Is this caused by the python version installed too old (v2.7.17) or other?

Thanks in advance!
Lianyuan

On Fri, Dec 11, 2020 at 2:49 PM Stanley Seibert <[hidden email]> wrote:
The development version of NumPy from Github requires Python 3.7 or later.

On Fri, Dec 11, 2020 at 1:35 PM Lianyuan Zheng <[hidden email]> wrote:
Hello,

On my linux server, I downloaded the NUMPY package from GitHub (git clone https://github.com/numpy/numpy.git) and then accessed the directory "numpy".  When I typed command "python setup.py install", it shows the following message:

  File "setup.py", line 51
    f"NumPy {VERSION} may not yet support Python "
                                                 ^
SyntaxError: invalid syntax

Obviously the installation failed.  Which python version is needed for this numpy package?  The python version installed is version 2.7.5.

Thanks,
Lianyuan



_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion
_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion

_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Installing numpy

bashtage

NumPy does not support Python 2.7. If you must use 2.7 you need to use NumPy 1.16.6.  Otherwise, you should probably be using Python 3.8 for new work.

 

Kevin

 

 

From: [hidden email]
Sent: Monday, December 14, 2020 2:15 PM
To: [hidden email]
Subject: Re: [Numpy-discussion] Installing numpy

 

Hello,

 

When I run the command "python numpy install", it shows the following error:

 

Traceback (most recent call last):

  File "setup.py", line 27, in <module>

    import versioneer

  File "./numpy/versioneer.py", line 1739

    file=sys.stderr)

        ^

SyntaxError: invalid syntax

 

Is this caused by the python version installed too old (v2.7.17) or other?

 

Thanks in advance!

Lianyuan

 

On Fri, Dec 11, 2020 at 2:49 PM Stanley Seibert <[hidden email]> wrote:

The development version of NumPy from Github requires Python 3.7 or later.

 

On Fri, Dec 11, 2020 at 1:35 PM Lianyuan Zheng <[hidden email]> wrote:

Hello,

 

On my linux server, I downloaded the NUMPY package from GitHub (git clone https://github.com/numpy/numpy.git) and then accessed the directory "numpy".  When I typed command "python setup.py install", it shows the following message:

 

  File "setup.py", line 51

    f"NumPy {VERSION} may not yet support Python "

                                                 ^

SyntaxError: invalid syntax

 

Obviously the installation failed.  Which python version is needed for this numpy package?  The python version installed is version 2.7.5.

 

Thanks,

Lianyuan

 

 

 

_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion

_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion

 


_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Installing numpy

mattip
Administrator
In reply to this post by Lianyuan Zheng

NumPy HEAD does not support python2. You should use v1.16.6 which was the last release to support python2.

Matti


On 12/14/20 4:14 PM, Lianyuan Zheng wrote:
Is this caused by the python version installed too old (v2.7.17) or other?


_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Installing numpy

ralfgommers


On Mon, Dec 14, 2020 at 3:26 PM Matti Picus <[hidden email]> wrote:

NumPy HEAD does not support python2. You should use v1.16.6 which was the last release to support python2.


That said, we should raise a comprehensible error. As well as write a test that checks we avoid py27 syntax errors like f-strings in setup.py

Cheers,
Ralf


_______________________________________________
NumPy-Discussion mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/numpy-discussion