problem re-installing my own package

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

problem re-installing my own package

lorenzo bolla
I'm having problems re-installing a package of mine, that uses numpy and scipy.
can it be due to some recent changes in numpy (scons?)

here is the error message I have:

=======================
$ python setup.py install
running install
running build
running scons
Traceback (most recent call last):
  File "setup.py", line 71, in <module>
    setup_package()
  File "setup.py", line 64, in setup_package
    configuration = configuration)
  File "c:\Python25\Lib\site-packages\numpy\distutils\core.py", line 184, in setup
    return old_setup(**new_attr)
  File "c:\Python25\lib\distutils\core.py", line 151, in setup
    dist.run_commands()
  File "c:\Python25\lib\distutils\dist.py", line 974, in run_commands
    self.run_command(cmd)
  File "c:\Python25\lib\distutils\dist.py", line 994, in run_command
    cmd_obj.run()
  File "c:\Python25\Lib\site-packages\numpy\distutils\command\install.py", line 16, in run
    r = old_install.run(self)
  File "c:\Python25\lib\distutils\command\install.py", line 506, in run
    self.run_command('build')
  File "c:\Python25\lib\distutils\cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "c:\Python25\lib\distutils\dist.py", line 994, in run_command
    cmd_obj.run()
  File "c:\Python25\Lib\site-packages\numpy\distutils\command\build.py", line 38, in run
    self.run_command('scons')
  File "c:\Python25\lib\distutils\cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "c:\Python25\lib\distutils\dist.py", line 993, in run_command
    cmd_obj.ensure_finalized()
  File "c:\Python25\lib\distutils\cmd.py", line 117, in ensure_finalized
    self.finalize_options()
  File "c:\Python25\Lib\site-packages\numpy\distutils\command\scons.py", line 234, in finalize_options
    force=self.force)
  File "c:\Python25\Lib\site-packages\numpy\distutils\ccompiler.py", line 366, in new_compiler
    compiler = klass(None, dry_run, force)
  File "c:\Python25\Lib\site-packages\numpy\distutils\mingw32ccompiler.py", line 46, in __init__
    verbose,dry_run, force)
  File "c:\Python25\lib\distutils\cygwinccompiler.py", line 84, in __init__
    get_versions()
  File "c:\Python25\lib\distutils\cygwinccompiler.py", line 424, in get_versions
    ld_version = StrictVersion(result.group(1))
  File "c:\Python25\lib\distutils\version.py", line 40, in __init__
    self.parse(vstring)
  File "c:\Python25\lib\distutils\version.py", line 107, in parse
    raise ValueError, "invalid version number '%s'" % vstring
ValueError: invalid version number '2.18.50.20080523'
=======================

thank you in advance.
L.

_______________________________________________
Numpy-discussion mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/numpy-discussion